> 服务器 >

宝塔Windows面板升级失败的解决方案

来源:网络 文章列表 2021-02-12 8
当前面板Python版本过低,请立即升级!当前升级面板Python环境,无法自动升级,请按照步骤升级。我手上有一台Windows服务器安装的也是宝塔的面板

当前面板Python版本过低,请立即升级!当前升级面板Python环境,无法自动升级,请按照步骤升级。我手上有一台Windows服务器安装的也是宝塔的面板,今天浏览后台的时候发现服务器的宝塔面板版本很低,于是我就点了升级,和Linux的版本不一样,Windows的版本有点问题,点了升级后会弹出一个警告,说:

当前升级面板Python环境,无法自动升级,请按照步骤升级:

1. 下载所需文件到远程服务器,立即下载文件

2. 通过远程桌面连接至服务器

3. CMD命令行执行升级脚本

大概如下图所示:

宝塔Windows面板升级报错

这里报错的原因是说我的Python版本过低,请立即升级。我想着,这个是要升级版本,于是我根据上面的提醒,点击了“立即下载文件”,随着我的点击后,第3步里会弹出CMD命令行执行升级脚本。

于是我进入到了我的Windows服务器,在Windows服务器里用CMD命令执行这段代码,结果发现,还是有问题。找不到执行的这个文件「 D:/BtSoft/update/update.bat 」,于是我根据提醒的报错路径,到了我的宝塔面板文件夹。

 

因为我安装在我的电脑D盘,这里就前往「 D:/BtSoft/update/update.bat 」,发现 update.bat 这个文件不存在,就连 update 文件夹都没有。

文件脚本都没有,那肯定会报错。

 

宝塔Windows面板升级报错解决方案

其实解决方案很简单,只要在宝塔面板的后台(网址后台),点击右上角的修复面板,然后稍等片刻,再按照上面的步骤,重新点击升级,然后这一次点击“立即下载文件”就会把对应的脚本下载好。

这个时候你再通过远程桌面连接至服务器,去用CMD命令行执行升级脚本就不会出现报错的情况了。

如下图所示:

这里要重点提醒各位,在升级完成后一定要把对应的脚本文件删除。

我这里是直接把「 D:/BtSoft/update/ 」这个文件夹删除,也就是把 update 这个文件夹删了。

版权声明

本站部分原创文章,部分文章整理自网络。如有转载的文章侵犯了您的版权,请联系站长删除处理。如果您有优质文章,欢迎发稿给我们!联系站长:
愿本站的内容能为您的学习、工作带来绵薄之力。

评论

  • 随机获取
点击刷新
精彩评论